Go to file
Thomas Goyne 20470ea682 Actually register the SSA subtitle format 2014-08-10 06:52:58 -07:00
.nuget Move everything up a level since the root dir no longer has stuff 2014-03-11 12:14:57 -07:00
automation Convert the clipboard module to the ffi 2014-07-28 15:52:37 -07:00
build Shut up strdup "deprecation" warnings 2014-07-28 15:52:37 -07:00
docs Modify aegisub_convert_docs.pl to produce a static mirror suitable for serving on a web site 2012-09-03 17:26:49 -07:00
libaegisub Convert the re module over to the LuaJIT ffi 2014-07-28 12:30:44 -07:00
m4macros Remove some pointless configure checks 2014-04-29 07:23:02 -07:00
packages Remove the in-repo copy of the fontconfig config files 2014-06-24 09:06:32 -07:00
po add '(Language)' after translated labels as suggested on the forums: http://forum.aegisub.org/viewtopic.php?f=5&t=66925#p91569 2014-07-28 12:08:23 -07:00
src Actually register the SSA subtitle format 2014-08-10 06:52:58 -07:00
tests Add simple type -> type name string compile time reflection stuff 2014-07-28 12:30:44 -07:00
tools Trim a bit more out of the ICU data files 2014-06-26 16:50:43 -07:00
vendor Update ffms2 2014-07-23 15:05:58 -07:00
.gitignore Move the desktop dir under the packages dir 2014-06-09 17:20:56 -07:00
.gitmodules Use wx's vendored copy of zlib rather than having a second copy in a submodule 2014-05-12 17:42:26 -07:00
.travis.yml Swallow spam from coveralls submission 2014-07-06 19:25:49 -07:00
Aegisub.sln Add custom build system for wxWidgets 2014-05-13 11:02:46 -07:00
LICENCE Move everything up a level since the root dir no longer has stuff 2014-03-11 12:14:57 -07:00
Makefile Remove the in-repo copy of the fontconfig config files 2014-06-24 09:06:32 -07:00
Makefile.inc.in Add -DBOOST_SYSTEM_NO_DEPRECATED to Boost's CPPFLAGS 2014-06-29 10:45:26 -07:00
Makefile.target Move some of the audio provider machinery to libaegisub 2014-07-10 11:44:56 -07:00
README.md Update readme 2014-05-10 08:19:59 -07:00
acinclude.m4 Decruftify and fix the boost configure checks 2014-04-28 18:37:43 -07:00
autogen.sh Move everything up a level since the root dir no longer has stuff 2014-03-11 12:14:57 -07:00
config.guess update config.guess and config.sub 2014-07-28 12:08:23 -07:00
config.sub update config.guess and config.sub 2014-07-28 12:08:23 -07:00
configure.ac Don't version the executable on Linux 2014-07-23 15:29:54 -07:00
header.mk Convert the build system to non-recursive make 2014-06-17 11:37:20 -07:00
install-sh Move everything up a level since the root dir no longer has stuff 2014-03-11 12:14:57 -07:00

README.md

Aegisub

For binaries and general information see the homepage.

The bug tracker can be found at http://devel.aegisub.org.

Support is available on the forums or on IRC.

Building Aegisub

Windows

Prerequisites:

  1. Visual Studio 2013 (Express edition is good enough) or the Windows 8.1 SDK (command line builds only).
  2. A recent DirectX SDK
  3. Yasm installed to somewhere on your path.

There are a few optional dependencies:

  1. msgfmt, to build the translations
  2. WinRAR, to build the portable installer
  3. InnoSetup, to build the regular installer

All other dependencies are either stored in the repository or are included as submodules.

Building:

  1. Clone Aegisub's repository recursively to fetch it and all submodules: git clone --recursive git@github.com:Aegisub/Aegisub.git
  2. Open Visual Studio from the VS2013 Native Tools Command Promp using devenv.exe /useenv (required for the build system to be able to find nmake.exe for building wxWidgets)
  3. Open Aegisub.sln
  4. Build the solution.
  5. Copy the contents of an existing Aegisub install into the aegisub/aegisub/bin directory (not strictly required, but you'll be missing a lot of functionality otherwise).

For actual development work you will probably want to mostly use the "Debug-MinDep" configuration (which disables building most of the projects), as the dependency checking is pretty slow.

License

All source files in this repository are licensed under either 3-clause BSD or ISC licenses. In practice, Aegisub binaries are usually GPL licensed due to the dependencies.