Go to file
Marcin Kurczewski a4bde47c5c Fix MRU menus (#48)
Broken in 9bbfdddde0. I don't understand
why the author made such a change, so I left their solution with #ifdef
guard.
2018-05-28 21:24:23 +02:00
.nuget Move everything up a level since the root dir no longer has stuff 2014-03-11 12:14:57 -07:00
automation Add support for reading waveform selection in LUA 2018-03-03 12:51:49 -08:00
build Set ffmpeg's yasm include paths correctly 2018-05-25 22:32:27 +02:00
docs Modify aegisub_convert_docs.pl to produce a static mirror suitable for serving on a web site 2012-09-03 17:26:49 -07:00
libaegisub Drop Windows XP support 2018-05-25 08:27:29 +02:00
m4macros added missing files (#57) 2018-04-29 12:59:48 -07:00
packages build: sort wildcard results for repeatable builds (#44) 2017-03-30 10:08:30 -07:00
po it.po: fix typo (#59) 2018-04-29 13:00:11 -07:00
src Fix MRU menus (#48) 2018-05-28 21:24:23 +02:00
tests Makefiles: replace the use of subst macro with patsubst (#56) 2018-03-05 09:28:29 -08:00
tools Add CFLAGS_PTHREAD/LIBS_PTHREAD to everything needing them 2016-03-05 11:23:46 -08:00
vendor Makefiles: replace the use of subst macro with patsubst (#56) 2018-03-05 09:28:29 -08:00
.gitignore Move the desktop dir under the packages dir 2014-06-09 17:20:56 -07:00
.gitmodules remove fontconfig submodule 2018-03-03 12:46:44 -08:00
.travis.yml Build with boost 1.60 when using GCC 5 on Travis 2016-03-05 11:23:46 -08:00
Aegisub.sln Remove fontconfig entirely from the Windows build 2015-12-29 20:08:07 -08:00
LICENCE Move everything up a level since the root dir no longer has stuff 2014-03-11 12:14:57 -07:00
Makefile Remove the in-repo copy of the fontconfig config files 2014-06-24 09:06:32 -07:00
Makefile.inc.in Bump minimum macOS version to 10.8 2017-07-04 12:31:55 -07:00
Makefile.target Bump minimum macOS version to 10.8 2017-07-04 12:31:55 -07:00
README.md fix(updated-macos-build): update Homebrew and wxWidgets instructions in README 2018-03-31 02:58:27 +02:00
acinclude.m4 Build: update boost m4 macros 2018-01-27 11:32:27 -08:00
autogen.sh Move everything up a level since the root dir no longer has stuff 2014-03-11 12:14:57 -07:00
config.guess update config.guess and config.sub 2014-07-28 12:08:23 -07:00
config.sub update config.guess and config.sub 2014-07-28 12:08:23 -07:00
configure.ac Build: update boost m4 macros 2018-01-27 11:32:27 -08:00
header.mk Switch to a maintained fork of universalchardet 2016-02-09 20:29:29 -08:00
install-sh Move everything up a level since the root dir no longer has stuff 2014-03-11 12:14:57 -07:00

README.md

Aegisub

For binaries and general information see the homepage.

The bug tracker can be found at http://devel.aegisub.org.

Support is available on the forums or on IRC.

Building Aegisub

Windows

Prerequisites:

  1. Visual Studio 2015 (the free Community edition is good enough)
  2. The June 2010 DirectX SDK (the final release before DirectSound was dropped)
  3. Yasm installed to somewhere on your path.

There are a few optional dependencies:

  1. msgfmt, to build the translations
  2. WinRAR, to build the portable installer
  3. InnoSetup, to build the regular installer

All other dependencies are either stored in the repository or are included as submodules.

Building:

  1. Clone Aegisub's repository recursively to fetch it and all submodules: git clone --recursive git@github.com:Aegisub/Aegisub.git This will take quite a while and requires about 2.5 GB of disk space.
  2. Open Aegisub.sln
  3. Build the BuildTasks project.
  4. Build the entire solution.

You should now have a bin directory in your Aegisub directory which contains aegisub32d.exe, along with a pile of other files.

The Aegisub installer includes some files not built as part of Aegisub (such as Avisynth and VSFilter), so for a fully functional copy of Aegisub you now need to copy all of the files from an installed copy of Aegisub into your bin directory (and don't overwrite any of the files already there). You'll also either need to copy the automation directory into the bin directory, or edit your automation search paths to include the automation directory in the source tree.

After building the solution once, you'll want to switch to the Debug-MinDep configuration, which skips checking if the dependencies are out of date, as that takes a while.

OS X

A vaguely recent version of Xcode and the corresponding command-line tools are required. Nothing older than Xcode 5 has been tested recently, but it is likely that some later versions of Xcode 4 are good enough.

For personal usage, you can use homebrew to install almost all of Aegisub's dependencies:

brew install autoconf ffmpeg freetype gettext ffms2 fftw fribidi libass m4
brew install --devel --with-gc64 luajit
brew install --HEAD icu4c
brew link --force icu4c
brew link --force gettext
brew install --HEAD --c++11 --with-icu4c boost

wxWidgets is located in vendor/wxWidgets, and can be built like so:

CPPFLAGS="$CPPFLAGS -D__ASSERT_MACROS_DEFINE_VERSIONS_WITHOUT_UNDERSCORES=1" \
./configure --disable-aboutdlg --disable-animatectrl --disable-aui --disable-any \
--disable-bannerwindow --disable-base64 --disable-calendar --disable-caret \
--disable-cmdline --disable-colourpicker --disable-compat28 --disable-config \
--disable-constraints --disable-datepick --disable-dctransform --disable-debugreport \
--disable-dialupman --disable-docview --disable-filehistory --disable-finddlg \
--disable-fs_archive --disable-fs_inet --disable-fs_zip --disable-fsvolume \
--disable-fswatcher --disable-gif --disable-help --disable-html --disable-ipc \
--disable-joystick --disable-jpeg --disable-largefile --disable-markup --disable-mdi \
--disable-mediactrl --disable-metafiles --disable-miniframe --disable-notifmsg \
--disable-numberdlg --disable-pcx --disable-pnm --disable-postscript \
--disable-prefseditor --disable-printarch --disable-progressdlg --disable-propgrid \
--disable-protocol --disable-protocols --disable-rearrangectrl --disable-ribbon \
--disable-richtext --disable-richtooltip --disable-snglinst --disable-sockets \
--disable-sockets --disable-sound --disable-splash --disable-splines \
--disable-std_iostreams --disable-svg --disable-tarstream --disable-tiff \
--disable-tipdlg --disable-tipwindow --disable-url --disable-webkit --disable-webview \
--disable-wizarddlg --disable-xrc \
--enable-geometry --enable-imaglist --enable-listctrl --enable-stc --with-cocoa \
--with-libpng=yes --with-macosx-version-min=10.9 \
--with-opengl \
--without-libjpeg --without-libtiff --without-regex \
&& make

Once the dependencies are installed, build Aegisub with autoreconf && ./configure --with-wxdir=/path/to/Aegisub/vendor/wxWidgets && make && make osx-bundle. autoreconf should be skipped if you are building from a source tarball rather than git.

Updating Moonscript

From within the Moonscript repository, run bin/moon bin/splat.moon -l moonscript moonscript/ > bin/moonscript.lua. Open the newly created bin/moonscript.lua, and within it make the following changes:

  1. Prepend the final line of the file, package.preload["moonscript"](), with a return, producing return package.preload["moonscript"]().
  2. Within the function at package.preload['moonscript.base'], remove references to moon_loader, insert_loader, and remove_loader. This means removing their declarations, definitions, and entries in the returned table.
  3. Within the function at package.preload['moonscript'], remove the line _with_0.insert_loader().

The file is now ready for use, to be placed in automation/include within the Aegisub repo.

License

All files in this repository are licensed under various GPL-compatible BSD-style licenses; see LICENCE and the individual source files for more information. The official Windows and OS X builds are GPLv2 due to including fftw3.